Bug? Backsampling with Noisy Relevance crashing

The engine

Bug? Backsampling with Noisy Relevance crashing

Postby jonnie » Thu Apr 12, 2012 2:15 pm

Hello,
I recently discovered the possibility to activate/deactivate relevance reasoning in SMILE and promptly stumbled over some crashes.
It happened with other algorithms as well (eg EpisSampling) but one case that I have isolated is using Backsampling with noisy relevance reasoning enabled (EnableNoisyMAXRelevance). The application crashes when calling UpdateBeliefs. If I use Lauritzen, or don't enable noisy relevance, the inference runs fine.
I should say the model has a lot of noisyMAX nodes.
I also was able to reproduce the crash in GeNIe (setting DSL_NOISYMAXRELEVANCE=1 in the network's user properties). I press the lightning button and after a second Windows tells me that GeNIe 2.0 has stopped working.
Why does that happen? Is it a bug?
Regards & thanks in advance :)
jonnie
 
Posts: 41
Joined: Mon Feb 06, 2012 12:49 pm

Re: Bug? Backsampling with Noisy Relevance crashing

Postby shooltz » Fri Apr 13, 2012 3:59 pm

Is it a bug?


It's definitely a bug. Can you post your network here so we can reproduce it locally?
shooltz
Site Admin
 
Posts: 811
Joined: Mon Nov 26, 2007 5:51 pm

Re: Bug? Backsampling with Noisy Relevance crashing

Postby jonnie » Fri Apr 13, 2012 5:36 pm

I'll see if the error occurs on an obfuscated model as well, and PM you about it.
Thanks for taking care of this :)
jonnie
 
Posts: 41
Joined: Mon Feb 06, 2012 12:49 pm

Re: Bug? Backsampling with Noisy Relevance crashing

Postby jonnie » Tue Apr 17, 2012 4:19 pm

Update: The crash is a segfault because of a NULL pointer dereference. The bug lies in 15yo legacy code and is therefore not probable to be fixed soon.
Workaround: don't use this combination :)
jonnie
 
Posts: 41
Joined: Mon Feb 06, 2012 12:49 pm

Re: Bug? Backsampling with Noisy Relevance crashing

Postby orzech » Wed Apr 18, 2012 7:52 pm

Thanks for the update!
orzech
 
Posts: 52
Joined: Wed Aug 04, 2010 11:40 pm

Re: Bug? Backsampling with Noisy Relevance crashing

Postby jonnie » Thu Apr 19, 2012 6:50 am

Update: after conducting experiments, I found that the bug occurs:

  • in ALL approximate algorithms, plus in LauritzenOld,
  • when noisy relevance is enabled, and the model contains noisy nodes,
  • only when evidence is set.
(Though I don't know if the latter is valid in general or only in my cases.)
jonnie
 
Posts: 41
Joined: Mon Feb 06, 2012 12:49 pm

Re: Bug? Backsampling with Noisy Relevance crashing

Postby shooltz » Fri Apr 20, 2012 11:25 pm

I can confirm the crash in four approximate algorithms and old Lauritzen implementation. However, AIS and EPIS return DSL_NO_USEFUL_SAMPLES (-5).
shooltz
Site Admin
 
Posts: 811
Joined: Mon Nov 26, 2007 5:51 pm

Re: Bug? Backsampling with Noisy Relevance crashing

Postby jonnie » Sun Apr 22, 2012 11:55 am

Oh, you're correct. I tested with a slightly different model; I'll PM that to you.
jonnie
 
Posts: 41
Joined: Mon Feb 06, 2012 12:49 pm


Return to SMILE

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest

cron