GeNIe missing Unicode encoding

The front end

GeNIe missing Unicode encoding

Postby orzech » Mon Dec 26, 2011 5:07 pm

Hello,

I've noticed that GeNIe's text fields don't support any Unicode-type encoding. Thus, it makes impossible to use GeNIe for editing node's documentation/properties in foregin languages (German, French etc...). Is there a chance you can solve this in the nearest future?

Kind Regards,
Piotr
orzech
 
Posts: 52
Joined: Wed Aug 04, 2010 11:40 pm

Re: GeNIe missing Unicode encoding

Postby shooltz » Fri Dec 30, 2011 7:00 pm

orzech wrote:I've noticed that GeNIe's text fields don't support any Unicode-type encoding. Thus, it makes impossible to use GeNIe for editing node's documentation/properties in foregin languages (German, French etc...).


SMILE and GeNIe save the .xdsl files with ISO-8859-1 encoding, which has full support for German and almost complete coverage for French - see http://en.wikipedia.org/wiki/ISO/IEC_8859-1

Is there a chance you can solve this in the nearest future?


I've added ticket for UTF-8 support to our tracker. However, the implementation is not trivial and it's not going to be done in the nearest future.
shooltz
Site Admin
 
Posts: 828
Joined: Mon Nov 26, 2007 5:51 pm

Re: GeNIe missing Unicode encoding

Postby orzech » Sun Jan 01, 2012 1:28 pm

Thank you. Unfortunately string encoding in C++ is really a pain... :/

Good luck and Happy New Year
orzech
 
Posts: 52
Joined: Wed Aug 04, 2010 11:40 pm


Return to GeNIe

Who is online

Users browsing this forum: No registered users and 1 guest

cron